Package0.11Cryptography
jose
JSON Object Signing and Encryption (JOSE) and JSON Web Token (JWT) library
- Version0.11
- CategoryCryptography
- LicenceApache-2.0
- AuthorFraser Tweedale
- Maintainerfrase@frase.id.au
- Homepagegithub.com/frasertweedale/hs-jose
- Pinned byhackage jose 0.11
- Sourcehackage.haskell.org/package/jose-0.11
Modules
15 modules- Crypto.JOSE1Prelude for the library.
- Crypto.JOSE.AESKW2Advanced Encryption Standard (AES) Key Wrap Algorithm;
- Crypto.JOSE.Compact4JWS, JWE and some related specifications provide for "compact"
- Crypto.JOSE.Error12JOSE error types and helpers.
- Crypto.JOSE.Header27Types and functions for working with JOSE header parameters.
- Crypto.JOSE.JWA.JWE5JSON Web Encryption data types specified under JSON Web Algorithms.
- Crypto.JOSE.JWA.JWE.Alg1JSON Web Encryption algorithms.
- Crypto.JOSE.JWA.JWK49Cryptographic Algorithms for Keys.
- Crypto.JOSE.JWA.JWS1JSON Web Signature algorithms.
- Crypto.JOSE.JWE2
- Crypto.JOSE.JWK89A JSON Web Key (JWK) is a JavaScript Object Notation (JSON) data
- Crypto.JOSE.JWK.Store1Key stores. Instances are provided for JWK and JWKSet. These
- Crypto.JOSE.JWS24JSON Web Signature (JWS) represents content secured with digital
- Crypto.JOSE.Types12Data types for the JOSE library.
- Crypto.JWT29JSON Web Token implementation (RFC 7519). A JWT is a JWS
Description
Implementation of JSON Object Signing and Encryption (JOSE) and JSON Web Token (JWT; RFC 7519).
The JSON Web Signature (JWS; RFC 7515) implementation is complete.
EdDSA signatures (RFC 8037) and secp256k1 (RFC 8812) are supported.
JWK Thumbprint (RFC 7638) is supported.
JSON Web Encryption (JWE; RFC 7516) is not yet implemented.
The ECDSA implementation is vulnerable to timing attacks and should only be used for verification.
Depends on
16 packages- aeson-2.2.3.0in this set
- base-4.20.2.0with GHC
- base64-bytestring-1.2.1.0in this set
- bytestring-0.12.2.0with GHC
- concise-0.1.0.1in this set
- containers-0.7with GHC
- crypton-1.0.4in this set
- crypton-x509-1.7.7in this set
- lens-5.3.5in this set
- memory-0.18.0in this set
- monad-time-0.4.0.0in this set
- mtl-2.3.1with GHC
- network-uri-2.6.4.2in this set
- template-haskell-2.22.0.0with GHC
- text-2.1.3with GHC
- time-1.12.2with GHC